Cloudflare Outage Impacting Dashboard Access & Partner APIs

Incident Report for Postscript

Resolved

This incident has been resolved.
Posted Nov 28, 2025 - 18:37 UTC

Monitoring

We’ve implemented a resolution for the issue affecting Postscript login and partner APIs, and systems are functioning as expected. Message sending, popups, Onsite Opt-in, and subscriber experience were not impacted. We continue to monitor to ensure full stability.
Posted Nov 28, 2025 - 17:27 UTC

Identified

Postscript performance is degraded due to an upstream issue with Cloudflare. This is impacting some customers' ability to log into the application and our partner APIs. Our engineering team has begun migrating to our secondary CDN and are actively working to resolve this issue.

Important: Message sending, popups, link tracking, and subscriber experience are fully operational.
Posted Nov 28, 2025 - 16:48 UTC
This incident affected: Postscript API and Postscript Web Application (app.postscript.io).