Degraded Service
Incident Report for Postscript
Resolved
This incident is now resolved. Delayed application tasks have recovered successfully, and the application is functioning as expected.
Posted Jun 13, 2023 - 22:14 UTC
Monitoring
Our third-party cloud service provider (AWS) has resolved the root cause of the issue. Most of the application is now functioning as expected.

Legacy Campaign and Automation sending, Segment creation, and Analytics calculations are now operational and rapidly catching up on delays. We are continuing to monitor the situation closely as the application recovers.
Posted Jun 13, 2023 - 21:57 UTC
Update
Our third-party cloud service provider (AWS) is beginning to stabilize impacted services. Popups, Shopify webhook ingestion, and the External API are now operating normally.

Legacy Campaign and Automation sending, Segment creation, and Analytics calculations are still experiencing outages.
Posted Jun 13, 2023 - 21:07 UTC
Update
Due to ongoing issues with our third-party cloud service provider (AWS), Postscript popups are not visible for a majority of stores.
Posted Jun 13, 2023 - 20:42 UTC
Identified
Our third-party cloud service provider (AWS) has identified the root cause of the issue and are working towards a resolution.
Posted Jun 13, 2023 - 19:43 UTC
Investigating
Due to an issue with a third-party cloud service provider (AWS), we are currently experiencing degraded service to message sending, Shopify webhook ingestion, analytics, and our external API. The app (app.postscript.io) is still functional, though some features may be impacted. Flow Campaigns are unaffected.
Posted Jun 13, 2023 - 19:42 UTC
This incident affected: Postscript API.