Degraded Performance - Inbound & Links
Incident Report for Postscript
Resolved
This incident has been resolved.
Posted May 14, 2021 - 21:01 UTC
Monitoring
All services are currently healthy. We're monitoring the situation for further updates.
Posted May 14, 2021 - 20:43 UTC
Identified
We're investigating reports of slow performance across our API, webhooks and links and are closely monitoring the situation.
Posted May 14, 2021 - 20:22 UTC
This incident affected: Postscript API.